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2. Mitered-Corner Windows 

This document contains the steps required to generate Mitered-
Corner windows using the AutoDesk ® REVIT ® Architecture 2012 
application.  This document was originally created by me in support 
of the REVIT ® RockStar webinar series by William C. Harris.  The 
webinar was originally shown on November 5, 2008.  These steps 
were originally created specifically for use with the Revit ® 
Architecture 2009 application but the steps were updated by me to 
reflect the latest AutoDesk REVIT® Architecture 2012 application. 
An In-Place window family can be used to create mitered-corner 
windows.  Another option is to utilize a mitered-corner window model 
that uses Void Extrusions.  This document covers the creation of a 
mitered-corner window family useing Void Extrusions. 

Caveats 
The standard windows family can NOT be used to draw two windows 
in a corner or some similar approach because of the extra detail 
"symbolic" line work that displays in the floor plan view.  
In-Place families can NOT be copied to the clipboard because they 
are unique to each host wall.  Therefore, a unique In-Place family 
must be created for each mitered-corner window within your project. 
A legend can NOT be generated for an In-Place window family. 

Createing an In-Place window family 
The basic steps to create an In-Place window family are to: 

• Create the walls for your model 
• Create an In-Place window family 
• Create rough openings within each of the host walls 
• Locate and dimension the opening cuts 
• Create the mitered-corner window components such as 

sweeps, glazing, and so on 
• Specify a material for the window components 
• Schedule the mitered-corner window. 

The detailed steps for generating an In-Place mitered-corner window 
family are covered in the following sections.
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Create the walls for your model 

The following steps illustrate how to create four generic walls that are 
used in this training exercise. 

1. Select "File > "New" > "Project" within the Menu bar. 
  The "New Project" dialog box displays. 

2. Select the "OK" button within the "New Project" dialog box. 
  The "New Project" dialog box closes. 

3. Select the "Basics" tab within the Design bar. 
4. Select the "Wall" option within the "Basics" tab of the Design 

Bar. 
5. Select the "Chain" checkbox within the Options bar. 
6. Select the "Rectangle" button within the Options bar. 
7. Draw four walls by clicking then dragging the mouse 

downward to the right. 
8. Select the "3D" icon within the Toolbar to display the four 

walls you created. 
9. Select the "Shading With Edges" model graphic style view 

property within the View Control bar. 

Create an In-Place family 

The following steps illustrate how to create an In-Place family. 
1. Select the "Modeling" tab in the Design bar. 

Note:  Select the "More Tools" option within the "Modeling" 
tab of the Design bar if the "Create..." option is not displayed 
within the "Modeling" tab. 

2. Select the "Create..." option within the "Modeling" tab of the 
Design bar. 
The "Family Category and Parameters" dialog box displays. 

3. Scroll down and select the "Windows" family category within 
the "Family Category and Parameters" dialog box. 

4. Select the "OK" button within the "Family Category and 
Parameters" dialog box. 
Note:  This In-Place family is now assigned as a "Windows" 
family versus a door family, wall family, and so on. 
The "Family Category and Parameters" dialog box closes. 
The "Name" dialog box displays. 

5. Enter a unique name for your In-Place window family within 
the "Name" dialog box. 

6. Select the "OK" button within the "Name" dialog box. 
The "Name" dialog box closes. 
The "Family" tab displays within the Design bar. 
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Create a rough opening cut within the South host wall 

The following steps illustrate how to create a rough opening cut 
within the South host wall.  The In-Place Family used in this training 
will be located at the intersection of the South and East host walls of 
the model. 

1. Select "Opening..." within the "Family" tab of the Design bar. 
The "Select a host" dialog box displays. 

2. Select the "OK" button within the "Select a host" dialog box. 
Note:  The cursor changes into a target. 

3. Select the top edge of the south host wall. 
Note: The cursor changes into a pencil. 
The "Sketch" tab displays in the Design bar. 

4. Select the "Chain" checkbox within the Options bar. 
5. Select the "Rectangle" icon within the Options bar. 
6. Drag a rectangle for the opening on the south host wall by 

clicking on the south host wall where you want the top left 
corner of the opening cut to begin and then drag the cursor 
downward to the right to define the bottom right corner of the 
opening cut and click the mouse to end the sketch. 
You will accurately define the opening cut in a later step. 
Note:  Make sure you drag all the way to (or beyond) the 
right edge of the wall face. 

7. Select "Finish Sketch" within the "Sketch" tab of the Design 
bar. 
The cursor returns to an arrow shape. 
The "Family" tab displays within the Design bar. 
The opening cut in the south wall displays.  You can see the 
edge of the east wall in the corner which is why the opening 
cut does not appear to fully cut through the corner. 

Create a rough opening cut within the East host wall 

The following steps illustrate how to create a rough opening cut 
within the East host wall. 

1. Select "Opening..." within the "Family" tab of the Design bar. 
The "Select a host" dialog box displays. 

2. Select the "OK" button within the "Select a host" dialog box. 
Note:  The cursor changes into a target. 

3. Select the top edge of the east host wall. 
The "Sketch" tab in the Design bar displays. 

4. Select the "Chain" checkbox within the Options bar. 
5. Select the "Rectangle" icon within the Options bar. 
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6. Draw a sketch line rectangle for the opening on the east host 
wall. 
Note:  Begin the sketch at the endpoint of the upper right 
edge of the existing opening in the corner of the south host 
wall and then drag diagonally down to the right to match the 
bottom edge (height) of the existing opening in the south 
host wall and click the mouse to end the sketch. 

7. Select "Finish Sketch" within the "Sketch" tab of the Design 
bar. 
The "Family" tab  displays in the Design bar. 
Note:  You must match the edges of the opening cuts to 
clean up the corner before you can create the window 
components. 

Acurately locate and dimension the opening cut in the South host wall 

The following steps illustrate how to locate and dimention the 
opening cut within the South host wall. 

1. Select the South elevation in the Project Browser. 
Apply dimension lines to accurately define the placement 
and dimensions of the opening cut in the south host wall. 
Note:  The height of the opening cuts in both of the south 
and east host walls must be identical and aligned with each 
other. 

2. Select the south host wall opening cut. 
3. Select the "Edit" button within the Options bar. 

The "Sketch" tab displays in the Design bar and the sketch 
lines of the opening cut become purple. 

4. Select the right vertical sketch line of the opening cut and 
drag it to the wall face. 

5. Select "Finish Sketch" within the "Sketch" tab of the Design 
bar. 

Acurately locate and dimension the opening cut in the East host wall 

The following steps illustrate how to locate and dimention the 
opening cut within the East host wall. 

1. Select the East elevation in the Project Browser. 
2. Select the east wall opening cut sketch lines. 
3. Select the "Edit" button within the Options bar. 

The "Sketch" tab displays in the Design Bar and the sketch 
lines of the opening cut become purple. 

4. Select the left vertical sketch line of the opening cut and drag 
it to the wall face. 

5. Apply dimension lines to accurately define the placement 
and dimensions of the opening cut in the south host wall. 
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6. Select "Finish Sketch" within the "Sketch" tab of the Design 

bar. 
7. Select the "3D" button within the Toolbar to view your work. 

Draw the mitered-corner window components 

The following steps illustrate how to draw the mitered-corner window 
components. 

1. Select "Solid Form" > "Solid Sweep" within the "Family" tab. 
The "Sketch" tab displays in the Design bar. 

2. Select "Pick Path" within the "Sketch" tab of the Design bar. 
3. Select all of the outer edges of the two opening cuts within 

the host walls. 
Note:  You may have to select a line and extend it all the 
way to the corner. 

4. Select "Finish Path" within the "Pick Path" tab of the Design 
bar. 
The "Sketch" tab displays in the Design bar. 

5. Select "Finish Sweep" in the "Sketch" tab. 
6. Select "Profile" within the "Sketch" tab of the Design bar. 
7. Select the "Level 1" (Floor Plan) elevation view. 

The "Sketch" tab displays in the Design bar. 
8. Zoom into the corner opening. 
9. Select "Edit" within the Option bar. 
10. Select "Lines" within the "Sketch" bar. 
11. Select the "Chain" checkbox within the Option bar. 
12. Select the "Rectangle" icon within the Option bar.  
13. Draw the first horizontal rectangle for the window sweep. 
14. Draw the first smaller box for the window sweep above and 

centered on top of the larger rectangle. 
15. Delete the bottom of the smaller box and the top of the larger 

rectangle thereby creating an inverted "T" shape. 
16. Select "Finish Profile" in the "Sketch" tab in the Design bar. 
17. Select "Finish Sweep" within the "Sketch" tab. 
18. Select the "3D" icon within the Toolbar and view your work. 

Specify a material for the window component sweeps 

The following steps illustrate how to draw the mitered-corner window 
components. 

1. Select the window sweeps. 
2. Select the "Element Properties" icon within the Option bar. 

The "Element Properties" dialog box displays. 
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3. Select the "Materials"  parameter within the "Element 
Properties" dialog box. 
The "Materials" dialog box displays. 

4. Select "Wood - Cherry" or whichever material you want 
within the "Materials" dialog box. 

5. Select "OK" within the "Materials" dialog box. 
 The "Materials" dialog box closes. 

6. Select the "OK" button in the "Element Properties" dialog 
box. 
 The "Element Properties" dialog box closes. 

7. Select the "3D" icon within the Toolbar and view your work. 

Create the glass window panes 

The following steps illustrate how to create ther glass window panes. 
1. Select "Solid Form" > "Solid Extrusion" within the "Family" 

tab. 
The "Sketch" tab displays in the Design bar. 

2. Select the "Wireframe" and "Hidden Line" view properties 
within the View Control bar. 

3. Adjust the "View Range" parameter within the "Element 
Properties" dialog box if you can not see the component's 
symbolic lines within the plan view. 
Note: Change the "Cut Plane Offset" setting in order to view 
the symbolic lines in plan view if the symbolic lines are not 
displayed. 

4. Draw two rectangles within the plan view representing the 
two glass window panes that overlap in the corner. 

5. Trim the rectangles at the corner to create one "L"-shaped 
window pane. 

6. Select "Finish Sketch" in the "Sketch" tab in the Design bar. 
7. Select the window pane. 
8. Select the "Element Properties" icon within the Option bar. 

The "Element Properties" dialog box displays. 
Note:  The extrusion may by default be drawn at (and within) 
the bottom of the host walls. 

9. Lock the extrusion to the reference planes of the opening 
sweeps (top and bottom). 

10. Select the "Element Properties" icon in the Options bar. 
The "Element Properties" dialog box displays. 

11. Select the "Materials" parameter in the "Element Properties" 
dialog box. 
The "Materials" dialog box displays. 

12. Select the "glass" material selection within the "Materials" 
dialog box. 
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13. Select the "OK" button in the "Materials" dialog box. 
The "Materials" dialog box closes. 

14. Select "OK" in the "Element Properties" dialog box. 
The "Element Properties" dialog box closes. 

15. Close the family by selecting "Finish Family" within the 
"Family" tab of the Design bar. 

16. Select the "Shading With Edges" view properties within the 
View Control bar. 

Schedule the window 

The following steps illustrate how to schedule the window. 
1. Select the "View" tab within the Design bar. 
2. Select "Schedule/Quantity" within the "View" tab of the 

Design bar. 
The "Window Schedule" dialog box displays. 
Note:  The "Height" parameter was never specified. 

3. Select the "Drafting" tab of the Design bar. 
4. Select "Legend Component" within the "Drafting" tab of the 

Design bar. 
5. Select your In-Place window family name within the "Family" 

drop-down menu in the Option bar. 
Note:  You can NOT create a legend component for an In-
Place window at this time given the current software level! 

Use the file from David Ewing 
The following steps illustrate how to use the model file from David 
Ewing with Void Extrusions to generate a mitered-corner window. 
Note:  A Cut Extrusion removes a chunk of the wall. 
Note:  You can schedule and legend the windows created using this 
family. 
Note:  You must align the front of the window to the actual corner 
edge of the first host wall if the window is imbedded within the 
second host wall. 
Note:  You can modify the parameters of the window within the 
window's Element Properties dialog box. 
Note:  A mitered-corner window in an angled wall intersection can be 
created by altering the Angle parameter of the window family then 
changeing the angle of the wall to match. 
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Import the family file "corner Window Fixed Stears.rfa" into your project. 

The following steps illustrate how to import the family file into your 
project. 

1. Select "File > "Open…"  within the Menu bar. 
  The "Open" dialog box displays. 

2. Navigate to the location of the mitered-corner window file. 
3. Select the “corner Window Fixed Stears.rfa” file. 
4. Select the “Open” button within the “Open” dialog box. 

The “Open” dialog box closes. 
The mitered-corner window family is ready to be placed into a wall 
within your model. 
Note: The file can NOT be opened in earlier versions of the REVIT ® 
Architecture application. 
 
 


